Zum Hauptinhalt gehen

Sicherheitsrelevante Information:

Auswirkungen der Schwachstelle CVE-2023-31543 auf unsere Produkte
I. Zusammenfassung der Sicherheitslücke
Veröffentlichung:
30.11.2023

Beschreibung:
CVE-2023-31543: Eine Abhängigkeitsverwirrung in pipreqs v0.3.0 bis v0.4.11 erlaubt es Angreifern, einen beliebigen Code auszuführen, indem sie ein manipuliertes PyPI-Paket auf den gewählten Repository-Server hochladen. Diese Sicherheitslücke betrifft Fälle, in denen pipreqs v0.3.0 bis v0.4.11 verwendet wird.

CWE - CWE-427: Uncontrolled Search Path Element (4.12) (mitre.org)
II. Auswirkungen auf unsere Produkte:
Produkte von TA Triumph-Adler sind von dieser Schwachstelle nicht betroffen.